Outlook Plugin Not Working (Unsupported Version of Outlook)

Follow

It's worth checking which versions of Outlook and which Windows operating system supports the CANDDi for Outlook Plugin.

Windows 7 works with: 

  • Outlook 2013
  • Outlook 2016 

Windows 8 works with:

  • Outlook 2013
  • Outlook 2016

Windows 10 works with: 

  • Outlook 2010 
  • Outlook 2013 
  • Outlook 2016 

*If you're running Office 365 note that you're most likely running Outlook 2016 as part of the package

*Unfortunately Outlook for Mac is unsupported by the CANDDi for Outlook plugin

It's worthwhile upgrading to one of the latest packages if you're running an older version of Windows or Outlook. There are massive benefits to the security as well as being able to use the plugin!

If you are using a supported version of Outlook, but your plugin still doesn't seem to be working. View our Outlook Plugin Troubleshooting FAQ here.

Any questions, feel free to call your CANDDi Consultant on 0161 414 1080.

Have more questions? Submit a request

Comments